WordPress的几款代码高亮插件比较

作者: gaohailin 分类: 网站技术 发布时间: 2018-10-19 15:13

1、WP-SynHighlight
http://wordpress.org/extend/plugins/wp-synhighlight/
评价:这是最给力的一款,与其他插件不同的是,它不是通过手动加标签来实现代码板的,而是通过GUI来完成的,而且下面的那些缺点都没有
缺点:①服务器必须开启该插件(若服务器端插件关闭,则浏览器显示的格式将会错乱)

备注:GeSHi

2、Developer Formatter

http://wordpress.org/extend/plugins/devformatter/
不足:①复制到剪切板时代码中的空行或空格全变成乱码(如果存放复制内容的文件是UTF-8的,则不会乱码);②服务器必须开启该插件
备注:GeSHi
标签:

这种标签方式能跟大多数插件兼容,方便移植,而WP-SynHighlight不便于移植

GeSHi Source Colorer

http://wordpress.org/extend/plugins/geshi-source-colorer/

评价:貌似不错,但是在笔者的环境中就是启动不了
备注:GeSHi

WP-GeSHi-Highlight, WP-Syntax

http://wordpress.org/extend/plugins/wp-geshi-highlight/
http://wordpress.org/extend/plugins/wp-syntax/
不足:①代码不高亮,代码之间自动增加一空行
优点:①服务器关闭插件之后也能正常显示;②保持代码原格式(Tab 不转化)
备注:GeSHi

CodeColorer

http://wordpress.org/extend/plugins/codecolorer/
不足:①Tab 被转为4个空格;②服务器必须开启该插件
备注:GeSHi

SyntaxHighlighter

http://wordpress.org/extend/plugins/syntaxhighlighter/
不足:①Tab 被转为4个空格;②服务器必须开启该插件

FV Code Highlighter

http://wordpress.org/extend/plugins/fv-code-highlighter/
不足:Tab 被转为4个空格,只支持4中语言

发表评论

电子邮件地址不会被公开。 必填项已用*标注